First bloom has opened

A forum to discuss and share pictures of Helleborus plants.

First bloom has opened

Postby insam » Dec 20, 2006 12:26 pm

A lovely young seedling and welcome at this time of year. Happy holidays.
Joseph
You do not have the required permissions to view the files attached to this post.
insam
 
Posts: 160
Joined: Feb 24, 2005 7:45 pm
Location: TN, USDA 6-7

First bloom has opened

Sponsor

Sponsor
 

Postby impatience » Dec 21, 2006 2:36 am

yum! I really like the looks of that one.

I am assuming you are back home??
Gardening is the slowest of the performing arts.
User avatar
impatience
 
Posts: 1308
Joined: Jan 09, 2002 7:00 pm
Location: Oklahoma Zone 7

Postby Doris_J » Dec 31, 2006 5:43 pm

Nice! I'm still waiting for mine to open but it's that close!
User avatar
Doris_J
 
Posts: 2562
Joined: Oct 30, 2001 7:00 pm
Location: Washington state

Postby Dee » Jan 02, 2007 9:29 am

Oh I'm so glad this time of year has arrived again. I just love looking at everyone's beautiful hellebore blooms!!! :D I grow them too, but they are not nearly as lovely as folks in warmer climates. You get to grow the most beautiful ones. Thank your for sharing your pictures! :cool:
User avatar
Dee
 
Posts: 655
Joined: Oct 25, 2001 7:00 pm
Location: Indiana
USDA Zone: 5

Postby Chris_W » Jan 02, 2007 12:24 pm

I really thought it was too early for Hellebores to bloom yet, but then to my amazement we have them starting to bloom here now too. It's a crime, I tell you! Usually they bloom for us in early May, just as the nursery opens. Last year they bloomed in April before anyone had a chance to see them. But in January??? Oh well, at least we get to enjoy them, and hopefully there will still be a few blooms around later...
Image
User avatar
Chris_W
Administrator
 
Posts: 8365
Joined: Oct 05, 2001 7:00 pm
Location: Cement City, MI
USDA Zone: 5

Postby thy » Jan 18, 2007 4:02 pm

Thats a beauty :D

Mine, the usual red one and the white one :lol: are flowering too
Way to early and it is so muddy in the garden.I hardly see them .... I think I will bring in some of them
Against stupidity the gods themselves struggle in vain.
E-mail for pics hostapics@gmail.com
User avatar
thy
 
Posts: 9032
Joined: Sep 23, 2002 7:00 pm
Location: Denmark - 7B/8A Lat. 55,23
USDA Zone: 7

Postby kHT » Mar 16, 2007 10:49 am

insam, can we get an update on this one? Did it stay this nice? We have our first attempt to cossing bloom this last week and we are seeing speckles in it. I really like the pure color of this one.
User avatar
kHT
 
Posts: 10242
Joined: Oct 31, 2001 7:00 pm
Location: PNW, some where over the rainbow?
USDA Zone: 7-8 Z-nial

Re: First bloom has opened

Postby insam » Jan 25, 2009 10:17 pm

Oops, sorry karma. A little late but yes, it's a clean plant. This is another photo taken the same year (12/06). Unfortunately, it has bloomed early every year (apparently genetic). Might be a nice trait in a milder winter climate, but it can kill the reproductive parts of the early flowers in my garden.

Image
insam
 
Posts: 160
Joined: Feb 24, 2005 7:45 pm
Location: TN, USDA 6-7


Return to Hellebore Forum

Who is online

Users browsing this forum: CCbot crawler and 0 guests